HIGH 7.5 Maven

Apache Struts Improper Control of Dynamically-Managed Code Resources vulnerability

GHSA-729q-fcgp-r5xh · CVE-2023-41835

Published · Modified

AI SAST

Find this class of vulnerability in your own code

Corgea's AI-native static analysis detects vulnerabilities like this one across your repositories, ranks them by exploitability, and returns review-ready fixes.

Description

When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied.
Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fix this issue.

Ready to move

Start Securing

Free, no credit card | First findings in minutes