HIGH 7.5 Maven

Apache Struts is Vulnerable to DoS via File Leak

GHSA-xx7v-hqxh-cjr9 · CVE-2025-64775

Published · Modified

AI SAST

Find this class of vulnerability in your own code

Corgea's AI-native static analysis detects vulnerabilities like this one across your repositories, ranks them by exploitability, and returns review-ready fixes.

Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.

This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.

Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Ready to move

Start Securing

Free, no credit card | First findings in minutes