HIGH 7.5 PyPI

pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS)

GHSA-r9hx-vwmv-q579 · BIT-setuptools-2022-40897 · CVE-2022-40897 · PYSEC-2022-43012

Published · Modified

AI SAST

Find this class of vulnerability in your own code

Corgea's AI-native static analysis detects vulnerabilities like this one across your repositories, ranks them by exploitability, and returns review-ready fixes.

Description

Python Packaging Authority (PyPA)'s setuptools is a library designed to facilitate packaging Python projects. Setuptools version 65.5.0 and earlier could allow remote attackers to cause a denial of service by fetching malicious HTML from a PyPI package or custom PackageIndex page due to a vulnerable Regular Expression in package_index. This has been patched in version 65.5.1.

Ready to move

Start Securing

Free, no credit card | First findings in minutes