CRITICAL 9.8 Maven

Apache Struts vulnerable to path traversal

GHSA-2j39-qcjm-428w · CVE-2023-50164

Published · Modified

AI SAST

Find this class of vulnerability in your own code

Corgea's AI-native static analysis detects vulnerabilities like this one across your repositories, ranks them by exploitability, and returns review-ready fixes.

Description

An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution.
Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.

Ready to move

Start Securing

Free, no credit card | First findings in minutes