HIGH 8.8 PyPI

setuptools vulnerable to Command Injection via package URL

GHSA-cx63-2mw6-8hw5 · BIT-setuptools-2024-6345 · CVE-2024-6345 · PYSEC-2026-1918

Published · Modified

AI SAST

Find this class of vulnerability in your own code

Corgea's AI-native static analysis detects vulnerabilities like this one across your repositories, ranks them by exploitability, and returns review-ready fixes.

Description

A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.

Ready to move

Start Securing

Free, no credit card | First findings in minutes